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Chapter8 

High Frequency Structure——HFSS 

Simulator——HFSS
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 HFSS is a high-performance full-wave electromagnetic(EM) field simulator for

arbitrary 3D volumetric passive device modeling that takes advantage of the

familiar Microsoft Windows graphical user interface. 

 It integrates simulation , visualization, solid modeling, and automation in an easy-to-learn 

environment where solutions to your 3D EM problems are quickly and accurately obtained.

 Ansoft HFSS employs the Finite Element Method(FEM), adaptive meshing, and

brilliant graphics to give you unparalleled performance and insight to all of your

3D EM problems.

 Ansoft HFSS can be used to calculate parameters such as S Parameters,

Resonant Frequency, and Fields. Typical uses include:
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We will discuss some basic concepts and terminology used throughout the Ansoft HFSS 

application. It provides an overview of the following topics:

Introduction

Converting Older 
Files

Ansoft Terms

Getting Help

Overview

Fundamentals

Opening a Design

Setting Model Type

Parametric Model 
Creation

Boundary Conditions

Excitations

Analysis 
Setup

Data 
Reporting



Starting Ansoft HFSS

Converting Older HFSS file to HFSS v12 

 To access HFSS projects in an earlier version

① Select the menu item File > Open

② Open dialog:

A. Files of Type: Ansoft Legacy EM Projects (.cls)

B. Browse to the existing project and select the .cls file

C. Click the Open button





Project Manager Window

Design

Design Setup

Design Results

Project

Design Automation

•Parametric

•Optimization

•Sensitivity

•Statistical

Project  Manager



Property Window

Property

table Property

buttons

Property Window



3D Modeler Window

Model

3D Modeler

design tree

Graphics

area

Context menu

Right-click

Origin

Coordinate 

System (CS)

Ansoft 3D Modeler



Object View

Material

Object Command History

3D Modeler Design Tree

Object

Grouped by Material
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Ansoft HFSS Desktop：

The Ansoft HFSS Desktop provides an intuitive, easy-to-use interface for 

developing passive RF device models. Creating designs, involves the following:

1. Parametric Model Generation – creating the geometry, boundaries and

excitations

2. Analysis Setup – defining solution setup and frequency sweeps

3. Results – creating 2D reports and field plots

4. Solve Loop - the solution process is fully automated
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Opening a New project

 To open a new project:

1. In an Ansoft HFSS window, select the menu item File > New.

2. Select the menu Project > Insert HFSS Design.

Opening an Existing HFSS project

 To open an existing project:

1. In an Ansoft HFSS window,select the menu File > Open.Use the Open dialog to 

select the project.

2. Click Open to open the project



Set Solution Type

 1. Driven Modal - calculates the modal-based S-parameters. The S-matrix solutions 

will be expressed in terms of the incident and reflected powers of waveguide modes.

 2. Driven Terminal - calculates the terminal-based S-parameters of multiconductor

transmission line ports. The S-matrix solutions will be expressed in terms of terminal 

voltages and currents.

 3. Eignemode – calculate the eigenmodes, or resonances, of a structure. The 

Eigenmode solver finds the resonant frequencies of the structure and the fields at those 

resonant frequencies.

In the design of antenna,we often choose 

Driven Modal or Driven Terminal



Set Solution Type

 1. Driven Modal - calculates the modal-based S-parameters. The S-

matrix solutions will be expressed in terms of the incident and 

reflected powers of waveguide modes.

 2. Driven Terminal - calculates the terminal-based S-parameters of 

multiconductor transmission line ports. The S-matrix solutions will 

be expressed in terms of terminal voltages and currents.

 3. Eignemode – calculate the eigenmodes, or resonances, of a 

structure. The Eigenmode solver finds the resonant frequencies of 

the structure and the fields at those resonant frequencies.

In the design of antenna,we often choose 

Driven Modal or Driven Terminal
To set the solution type:

1. Select the menu item

HFSS > Solution Type

2. Solution Type Window:

① Choose one of the following:

Driven Modal

Driven Terminal

Eigenmode

② Click the OK button



Overview of the 3D Modeler User Interface



When using the 3D Modeler interface you will also interact with two additional

Property Window

Status Bar/Coordinate Entry

The Status Bar on the Ansoft HFSS Desktop Window displays the Coordinate Entry 

fields that can be used to define points or offsets during the creation of structural objects

The Property Window is used 

to view or modify the attributes 

and dimensions of structural 

objects



Creating and Viewing a Simple Structure

Creating 3D structural objects is accomplished by performing the following 

steps:

1. Set the grid plane

2. Create the base shape of the object

3. Set the Height



Create a Box

We will investigate creating a box to demonstrate these steps. These steps assume 

that project and a HFSS design have already been created. Three points are 

required to create the box. The first two form the base rectangle and the third sets 

the height

Point 1:

Defines the start point of the base rectangle

Point 2:

Defines the size of the base rectangle

Point 3: 

Defines the height of the Box



Create a Box  

1. Select the menu item 3D Modeler > Grid Plane > XY

2. Use the mouse to create the base shape

① Set the start point by positioning the active cursor and click the left 

mouse button.

② Position the active cursor and click the left mouse button to set the 

second point that forms the base rectangle

③ Set the Height by positioning the active cursor and clicking left 

mouse button.





Specifying Points

 Object Properties

By default the Properties dialog will appear after 

you have finished sketching an object. The position 

and size of objects can be modified from the dialog. 

This methodallows you to create objects by clicking 

the estimated values using the mouse and then 

correcting the values in the final dialog.



Point 1

Defines the material, display, and solve properties

Defined Project Material



Defining Parameters

 HFSS——Design Properties——.Add parameters

OR
 Select the command to parameterized

 Choose the value to change

 Enter a variable in replace of the fixed value

 Define the variable using any combination of math functions or design variables.

 The model will automatically be updated



Shortcuts

Since changing the view is a frequently used operation, some useful

shortcut keys exist. Press the appropriate keys and drag the mouse with

the left button pressed

ALT + Ctrl: Rotate

Shift + ALT: Dynamic Zoom

Shift + Ctrl: Move 

Ctrl+D to fit your screen



Combine Objects by Using Boolean Operations

Most complex structures can be reduced to combinations of simple 

primitives.Even the solid primitives can be reduced to simple 2D primitives that are 

swept along a vector or around an axis(Box is a square that is swept along a vector to 

give it thickness). The solid modeler supports the following Boolean operations:

Unite – combine multiple primitives

Unite disjoint objects

Separate Bodies to separate

Subtract – remove part of a primitive 

from another

Split – break primitives into multiple parts



 Definition of Boundary Conditions

 Select the object surface——

click the right ——Assign Boundary

 Perfect E 

（Perfect H is a perfect magnetic conductor. Forces E-Field 

tangential to the surface）
 Perfect H 

（Perfect H is a perfect magnetic conductor. Forces E-Field 

tangential to the surface.）
 Radiation

（Radiation boundaries, also referred to as absorbing boundaries , 

enable you to model a surface as electrically open: waves can 

then radiate out of the structure and toward the radiation 

boundary）



 Excitations is defined as the excitation source in the three-dimensional or two-dimensional object 

surface .HFSS defines a variety of excitations, including Wave Port/Lumped Port/Floquet

Port/Incident Wave/Voltage Source / Current Source/Magnetic Bias. 

 The antenna transmit signal  by means of a transmission line or waveguide, the connecting part 

between the antenna and a transmission line or waveguide is seen as a port plane . The excitation 

method of the Port plane in antenna design are Wave Port or Lumped Port.



 Wave Port:

If the port plane is touch the background plane, Wave Port is setted.

（ The width and height of wave port are less than half wave length, otherwise

It will Stimulate the waveguide mode)

 Lumped Port:

If the port plane is inside of model , Lumped Port is setted. 

 Wave Port

 Driven Modal:

when we set excitation , we must set the integration line to :

1.confirm the direction of the electric field (integration line arrow

represent the direction of positive electric filed) 

2.set integration path of the port voltage

 Driven Terminal:

we often set reference ground as the terminal line 

of reference conductor



 Wave Port

 Driven Modal:

when we set excitation , we must set the integration line to :

1.confirm the direction of the electric field (integration line arrow represent the direction of 

positive electric filed) 

2.set integration path of the port voltage

Click here to set the 

integration line

 Wave port integration line

 The arrow points the direction 

of positive electric filed



 Wave Port

 Driven Terminal:

we often set reference ground as the terminal line of reference conductor

selected
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Wave ports represent places in the geometry through which 

excitation signals enter and leave the structure. They are used 

when modeling strip lines and other waveguide structures (for 

example, rectangular or circular).. 



Lumped ports are similar to traditional wave ports, but can be located internally and have a 

complex user-defined impedance. Lumped ports compute S-parameters directly at the port. An 

example use is modeling microstrip structures. 

A lumped port can be defined as a rectangle from the edge of the trace to the ground or as a wave 

port. The default boundary is perfect H on all edges that do not come in contact with the metal or 

with another boundary condition.
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 Adding a Solution Setup

By default, the General Tab will be displayed. The Solution Frequency and the 

Convergence Criteria are set here.



 Enabling/Disabling a Solution Setup

By default, the General Tab will be displayed. The Solution Frequency and the 

Convergence Criteria are set here.



 Add Sweep 

After a Solution Setup has been 

added you can also add a Frequency 

Sweep .To do this, right-click on 

Setup in the HFSS Model Tree . The 

Edit Sweep window will appear



 Enabling/Disabling a Solution Setup

Sweep Type

Frequency Setup

After the sweep type has 

been chosen, the frequencies 

of interest must be specified.

There are three Frequency 

Setup Options：
Linear Step 

Linear Count  

Single Points  



 Validation check

 HFSS—— Validation check



 Plotting Data

 Types of Plots:

Rectangular Plot

Polar Plot

3D Rectangular Plot

3D Polar Plot

Smith Chart

Data Table

Radiation Pattern

To Create a Plot:

To Create a Plot：
1. Select HFSS > Results > Create Report

2. Select Report Type and Display Type from the selections above

3. Click OK and the Report Editor will be displayed



Try——Antenna Simulation  



1.Linear dipole antenna

• Arm of dipole：cylinder  (0,0,0.12)  r=0.5     h=23.88

• Feed port：Y-Z  plane    rectangle（0，-0.5，-0.12） 1,   0.24

• air： cylinder（0，0，-34）r=25.5 h=68



2. Microstrip antenna

• Substrate:  box (11,-13,0)  dx=22 dy=26 dz=1

• Ground: (11,-13,0)  dx=22 dy=26 dz=0

• Patch:        (6,-8,1)  12,16,0

(6,-3,1) 3,6,0

( 11,-0.9 ,1)  8,1.8,0

• Feed(wave port):  (11,-9, 0) 0,18,8 

Air  box (32,-22,0)  35,52,27




